Page 1 of 3

WitA Beta Testing feedback

PostPosted: 07 Jun 2019, 16:07
by super_dipsy
This thread might be useful for people to post if they have issues with the Beta Games. I will keep a list of bugs here: these are both WitA bugs and bugs brought in which affect other games.

BETA game went into confirmation on 7 joiners: FIXED
BETA game started after only 7 confirms: FIXED
Automatic disbands on other games were not happening: FIXED
- To do: See if we can get an auto-disband done in the Beta games
Filter for WitA games not working: FIXED
People other than nopun and me could start Wita games: FIXED
Flags not showing on roster: FIXED
Map view if you are not in the game is not shifting to the left: OPEN
Problems with errors referring to smar and cFon: FIXED
Order arrow not appearing when moving to Baia fe Paranagua: FIXED
Order arrow not appearing for Santa Fe de la Cruz: FIXED
Tabbar image issue: OPEN
Fleet occupying Nic is not changing territory colour: FIXED (at least for the future)

Re: WitA Beta Testing feedback

PostPosted: 07 Jun 2019, 16:34
by NoPunIn10Did
I've moved this to the WITA workshop subforum.

Re: WitA Beta Testing feedback

PostPosted: 07 Jun 2019, 16:35
by NoPunIn10Did
BUG:
Thumbnail flags for countries not shown except for Spain, which is currently showing the wrong flag.

Re: WitA Beta Testing feedback

PostPosted: 07 Jun 2019, 16:40
by super_dipsy
Oh damn, I forgot to move those in. Will do.

Also, there is a bug in that if you are not in the game but you view it, the map does not shift to the left as it does if you are in it.

Re: WitA Beta Testing feedback

PostPosted: 07 Jun 2019, 17:25
by NullSpeech
Santa Fe de la Vera Cruz does not show an arrow for the entered order. I tried both point and click and menu-based.

Re: WitA Beta Testing feedback

PostPosted: 07 Jun 2019, 17:47
by NullSpeech
The white background (paper.jpg) is not loaded.

The Tabbar image has a white line because of the increased width causing the tabbar.png image to repeat, showing a 1px-wide column of brightened pixels on the left-hand side in that image. I fixed the image and included it here.

Re: WitA Beta Testing feedback

PostPosted: 07 Jun 2019, 17:55
by NoPunIn10Did
NullSpeech wrote:The white background (paper.jpg) is not loaded.

The Tabbar image has a white line because of the increased width causing the tabbar.png image to repeat, showing a 1px-wide column of brightened pixels on the left-hand side in that image. I fixed the image and included it here.


The paper background not loading is intended. The other pixel issue might be fixable.

Re: WitA Beta Testing feedback

PostPosted: 07 Jun 2019, 19:26
by Charleroi
It looks as though I didn't receive an email notifying me that the game had begun. Only saw it when I checked my active games tab.

Re: WitA Beta Testing feedback

PostPosted: 08 Jun 2019, 14:34
by VGhost
I'm playing New Granada in 158145. Game is currently in the opening season. I've tested the following in both Opera and Firefox for Windows.

The point-and-click interface does not work for the fleet New Granada has in Cali.
UPDATE: The point-and-click did work once I moved an army there.

The drop-down order box loads with the following error messages but appears to work:

Notice: Undefined index: cFon in /home/playdip/domains/playdiplomacy.com/public_html/includes/classes/cgameplay.php on line 1458
Notice: Undefined index: smar in /home/playdip/domains/playdiplomacy.com/public_html/includes/classes/cgameplay.php on line 1426
Notice: Undefined index: smar in /home/playdip/domains/playdiplomacy.com/public_html/includes/classes/cgameplay.php on line 1433
Notice: Undefined index: smar in /home/playdip/domains/playdiplomacy.com/public_html/includes/classes/cgameplay.php on line 1400
Notice: Undefined index: smar in /home/playdip/domains/playdiplomacy.com/public_html/includes/classes/cgameplay.php on line 1407

Re: WitA Beta Testing feedback

PostPosted: 08 Jun 2019, 15:17
by Tortellacci
BUG: Moving to BaĆ­a de Paranagua results on no arrows appearing from Show Order Graphics.